Browser settings

Information about how to set up your browser to optimise LMS functions.

For the LMS to function correctly, your browser should have certain capabilities. This page performs a number of simple tests to help you assess your browser's suitability for use with the LMS. 

Some issues can be solved by clearing your cache.

Browser compatibility report

Recommended browsers

The following information has been sourced from the Blackboard Support website.

Browsers are changing all the time. While the latest release of each browser may not be listed here, in most cases new versions will function normally with the LMS. If you have a specific query about an issue with your browser and the LMS, please let us know.

If you are unsure, use this tool to check your browser version.

These browsers are supported in the LMS

Chrome 34
Firefox 24
Internet Explorer 9, 10 and 11
Safari 6 and 7

These browsers/technologies are NOT SUPPORTED in the LMS

Internet Explorer 8 and below
Firefox 23 and below
Chrome 29 and below
Safari 5 (or any version on Windows) and below
Java 5 and below